Audirvāna for LINUX and NAS (QNAP/Synology) officially released

Hello I’m just installed on Ubuntu 22. I see the icon on ubuntu. But I haven’t the core on my ios app. Do you do anything to activate audirvana on Ubuntu ? thanks lot

Audirvana, how you are impressed me!

Tried install on Raspberry Pi4 2gb ram with Moode 8.3.9 and i get errors unfortunately:

Unpacking audirvana-studio ( over ( …
dpkg: dependency problems prevent configuration of audirvana-studio:
audirvana-studio depends on libstdc++6 (>= 11); however:
Version of libstdc++6:arm64 on system is 10.2.1-6.

dpkg: error processing package audirvana-studio (–install):
dependency problems - leaving unconfigured
Errors were encountered while processing:


moode@moode:~ $ sudo apt-get install libstdc++6
Reading package lists… Done
Building dependency tree… Done
Reading state information… Done
libstdc++6 is already the newest version (10.2.1-6).
0 upgraded, 0 newly installed, 0 to remove and 87 not upgraded.

17 posts were split to a new topic: Installing Audirvāna on a SOtm-SMS200?

Waow! Can’t wait to test the Synology version! Will simplify my setup!
Never tried QNAP or any other Brand but Synology is impressive on many aspects. Never had any problem (except HDD failures, mainly affecting Seagate disks) for more than 10 years of use.


Jud, nice to see you here. It’s mounted under media

/media/jason/HQPMusic and it’s written in fstab. I guess I can change it.

Right now, the audirvana remote only sees /media/jason and then nothing.

edit: removing /jason from the path and mounting it one level deep at /media/HQPMusic did the trick.

1 Like

:+1: And you. Glad to see it worked!

I’m assuming you have the Audirvāna remote installed on iOS? On your phone are you asking to sign in with Audirvāna when the service starts?

Planing to try this one when Synology support is available. A docker container would be prefferable :+1:

1 Like

This is amazing news for the Linux Desktop. I’ve already used debtap to convert to an Arch Linux package, installed, and executed the binary from the /opt directory. Fantastic sound quality through ALSA. I’m not a Synology/QNAP user, but would definitely explore options on my TrueNAS Scale server. But again, the most exciting thing is having that signature Audirvana sound on my Linux desktop (why it sounds slightly different than Roon “bit perfect”, I don’t know.) Once this is stabilized/GA, it will run anywhere. Thanks for the amazing work Audirvana team.

1 Like

Interesting to see that Audirvana now ‘plays with’ the Pro-Ject Stream S2 Ultra.
Would be nice if Audirvana could come up with a build that could be installed on this streamer, which is a slightly jazzed up Raspberry Pi.

You’re doing better than I did! I tried debtap, even tried editing the resulting PKGBUILD, but at least on ArcoLinux (Arch-based distro), I keep getting a crash on startup. What distro are you using, plain Arch or something else?

Somewhat to my amazement Audirvana is running smoothly on my 2 gig Raspberry Pi4.

A question for @Antoine - is there support fort any of the common Pi HATs and if so how do I enable it?

Many thanks - this is excellent.


I’m using the Endeavour OS variant (fairly close to vanilla Arch), just to install more quickly while using Arch’s repos–a habit I formed after probably my 30th installation of Arch without the TUI installer a few years back. On Endeavour, these are the important bits that I ran:

Update debtap database

echo “Updating debtap database…”
sudo debtap -u

Convert .deb package to Arch package

echo “Converting .deb package to Arch package…”
sudo debtap “$DEB_PACKAGE”


sudo pacman -U audirvana-studio-

After that, I ran the process manually from the /opt directory for a quick test. Though, more recently (after reading the script) I used:

Enable for non-root user

/opt/audirvana/studio/ enable USERNAME

A few things I’ve noticed:

1.) I can’t play any Tidal tracks, I specifically looked for MQAs. I didn’t attempt pure FLAC via Tidal.
2.) Qobuz seems to work flawlessly.
3.) Sometimes connecting to my Linux instance of Audirvana Studio causes the Audirvana Remote to crash on Android 14, Google Pixel 7 Pro.
4.) I can’t seem to release Audirvana Studio’s hold on ALSA, which prevents me from switching to other audio sources.

I’m likely going to build an Ubuntu based Docker container to install the official DEB, and pass --device /dev/snd to it, so that the container has access to my iFi Zen DAC v2 USB sound device.


I just installed the Linux application. I’ve enabled run as service, service is running, firewall is off, but remote app is not detecting the linux server. What can I do? Thanks!

  • Have you tried restarting the service?

  • What’s the exact error message when you check the status?

  • Do you have avahi-daemon installed and running?

1 Like

joan@embysrv:/opt/audirvana/studio$ sudo ./ status
● audirvanaStudio.service - Run audirvanaStudio
Loaded: loaded (/etc/systemd/system/audirvanaStudio.service; enabled; vendor preset: enabled)
Active: active (running) since Sat 2024-04-13 20:00:08 CEST; 3s ago
Main PID: 7523 (audirvanaStudio)
Tasks: 68 (limit: 18906)
Memory: 7.2M
CPU: 18ms
CGroup: /system.slice/audirvanaStudio.service
└─7523 /opt/audirvana/studio/audirvanaStudio

abr 13 20:00:08 embysrv systemd[1]: Started Run audirvanaStudio.
abr 13 20:00:08 embysrv audirvanaStudio[7523]: 2024-04-13 20:00:08.790 [info]: ============= Started Logging, Audirvana Studio linux ========>
abr 13 20:00:08 embysrv audirvanaStudio[7523]: 2024-04-13 20:00:08.792 [info]: EULA not accepted yet, showing it

That’s an error message I got when avahi-daemon wasn’t installed or working properly. Check whether it’s installed and running.

1 Like

Afte installing avahi-daemon, the server is detected. Thanks!

1 Like

Thanks for your very detailed and helpful reply. I’ve now got Studio working on my favorite distro!

About Audirvāna not releasing exclusive hold of ALSA: If the unlock button doesn’t work (which IMO would be a UI bug), then I’m thinking the only answer for the time being would be stopping the service.

1 Like

I reached the same conclusion. Interestingly, when I start the audirvana-studio service after shutting it down like this, it holds on to the lock. Not a huge deal.

I did a bit more investigation on the Docker side of things, and it seems inevitable that mDNS/Avahi Daemon running in the container will need to be exposed at the host network level, which means that it will conflict with any Avahi Daemon running on the host. That said, if anyone wants to run this in a container on a server that isn’t running an Avahi daemon already, this is how it could be accomplished (in theory, I haven’t fully tested):

Create a file called Dockerfile with these contents:

# Use the latest Ubuntu LTS as base image
FROM ubuntu:22.04

# Avoid user interaction with tzdata
ENV DEBIAN_FRONTEND=noninteractive

# Update and install necessary packages
RUN apt-get update && \
    apt-get install -y --no-install-recommends \
    gdebi-core \
    avahi-daemon \

# Copy the Audirvana Studio deb package into the container
COPY audirvana-studio_2.8.1.1_amd64.deb /tmp/audirvana-studio_2.8.1.1_amd64.deb

# Install the Audirvana Studio deb package along with its dependencies
RUN gdebi -n /tmp/audirvana-studio_2.8.1.1_amd64.deb

# Clean up
RUN apt-get clean && rm -rf /var/lib/apt/lists/*

# Set up the entrypoint to start Avahi daemon and then Audirvana Studio
ENTRYPOINT ["sh", "-c", "service avahi-daemon start && /opt/audirvana/studio/audirvanaStudio"]

Build your container (while in the dir with your Dockerfile & Audirvana deb file)

docker build -t audirvana-studio .

Run this quick and dirty command to test (you may want to limit container caps for production)

docker run --rm -d --network host --privileged --device /dev/snd audirvana-studio

It’s probably a good idea to mount the audirvana config in a Docker volume or bind mount to the desired directory on the host so that when the container is removed, you do not lose config data.

Any way, some variant of this is good for a Linux server with no Avahi Daemon running on the host.

Running on a Linux Host that already has an Avahi Daemon

If you’d like to run on an existing Linux Desktop with Avahi already installed, you would need to modify your Dockerfile to ensure that you configure NSSwitch to use the mdns4 plugin. You can probably do this by modifying the /etc/nsswitch.conf file within the container to look like this:

# /etc/nsswitch.conf
hosts: files mdns4_minimal [NOTFOUND=return] dns mdns4

In the Dockerfile, this might be accomplished by:

# Modify nsswitch.conf
RUN sed -i 's/hosts: files dns/hosts: files mdns4_minimal [NOTFOUND=return] dns mdns4/g' /etc/nsswitch.conf

When you’re ready to run the new container, you’ll want to add these flags: -v /var/run/dbus:/var/run/dbus -v /var/run/avahi-daemon/socket:/var/run/avahi-daemon/socket which (in theory) give access to your host operating system’s Avahi daemon.

Alas, I do not have time to fully test this today. Others are welcome to try. No warranties/guarantees though.