Audirvana Windows 2.5.2 firewall diagnostics false positives

Audirvana 2.5.2 firewall problem v2.4.0 ok

In 2.5.2. there is a new warning message if your firewall is blocking connections:

See the release notes below.
Release note Audirvāna Studio 2.5.2 - Audirvana News / Release Notes - Audirvana

That is not a problem, but new functionality compared to 2.4. Check your firewall settings.

Same thing happening to me, the firewall is not blocking any connections and still it doesn’t work :frowning:

1 Like

Same here. I didn’t block Audirvana on my firewall software. But still shows the firewall block Audirvana. I believe this is a bug. I’ve already rolled back to former version 2.5.1. The message Window annoys me a lot.

Please correct the issue, pls.

You do realize there is a memory leak that exists in 2.5.1 and was fixed in 2.5.2…
:notes: :eye: :headphones: :eye: :notes:


I know, but the error warning window annoys, which makes me feel upset!

The memory leak was not for all. For me was not present (Windows 11). About the firewall Warning: 1.set your connection as “private” 2.enable firewall If disabled 3.set Audirvana as exception. For me worked like a charm - it’s a feature not a bug to ensure best remote app connectivity.

I tried your guide now but it still doesn’t work for me.Please fix this.

I’m a user like you, not a part of Audirvana team. Just told you what I did. Sorry to hear it din’t work for you. Maybe some problems with your os/router? Really don’t know. You can reset firewall, network, disable IPv6, turn off / configure av (maybe has firewall integrated), reinstall windows or wait for Antoine answer next week. I’m sorry to hear it didn’t work.

I have this same issue and have gone back to AS 2.4,0 for the time being as I had mentioned on a similar thread here. Tried some fixes recommended to me with no luck.
I have McAfee (came installed on my PC) which uses it’s own firewall that could be further complicating this issue.
I am going to wait and see what Antoine can come up with before proceeding.

Just updated today and am getting these Firewall Issue warnings. Attempted to do as the notice suggested but these warnings are still there so I don’t know how to proceed. AS appears to be working before and after I attempted to fix this.
Any way to go back to 2.5.1?

You don’t want to do that, read the latest forum post.

Roll back to 2.4

Thanks for the heads-up, had not seen this post. For some reason 2.5.2 is giving me a little burst of noise between tracks occasionally when upsampling PCM to DSD (Kernel) that was not occurring in 2.5.1.
However I will take your advice and steer clear of 2.5.1.

remove the firewall rules of adirvana and reopen the player then simply click to allow, and done…at least for me that works.

1 Like

Thanks! Thought I did that already so redid it but Firewall Issues warning is still there.
This is on Windows 11 Desktop.
Audirvana Firewall

I had the same issue. Restart Audirvana after you did that. The message should be gone.

All steps:

  • Close Audirvana.
  • Go in Windows to ‘Firewall with advanced settings’.
  • Remove all Audirvana entries.
  • Start Audirvana.
  • Windows now shows a Firewall dialog to allow Audirvana. Allow that.
  • Close Audirvana.
  • Start Audirvana.

Thanks for the step by step guide. Tried this a couple of times but no luck. Hope I am doing it right still keep getting these messages.

From you screenshot it seems you are not in Firewall with advanced settings but in the Control Panel.
Sorry all my screens below are in Dutch, but it should be clear what they mean.

Close Audirvana.

Go to the screen below (type in your Windows startmenu (in the search) 'Firewall with advanced settings). (So do not go to the control panel).

Click on that and now you should see this screen:

Remove in the incoming rules all the Audirvana entries (select all the Audirvana entries and press the delete key):

Remove in the outgoing rules all Audirvana entries (select all the Audirvana entries and press the delete key):

The number of Audirvana entries you see in your firewall can differ from mine.

Open Audirvana:
Now Windows shows this screen (asking to allow Audirvana on your network). Click on Allow and that Windows message closes:

Now if you see this in Audirvana:

Click on OK on that screen and after that close Audirvana.

It can also be that Audirvana only shows a red exclamation mark. This also means there is a warning about the firewall:

In that case simply close Audirvana.

Now open Audirvana again and all should be fine.

1 Like

Thank you for the easy to follow instructions and all your help.
I had no Audirvana in “incoming rules” but had some in my “outgoing rules”. I deleted them all. I then opened Audirvana but did not get Windows showing me the screen to allow Audirvana on my network. Only the same as before message shown here. Tried repeating this process a couple of times including a PC restart but unfortunately the same result.
Audirvana appears to be working despite all of this but is very frustrating.

Anti-Virus Firewall, could this be a problem?