Duplicate Tracks 3.5

Hi all,

All of a sudden Audirvana says I have duplicate tracks in some albums. There are no duplicate tracks in the source folders. If I move the duplicates to the recycle bin and empty it, both the original and duplicate are deleted.

I’ve tried checking database integrity, rebuilding the indexes, and defragmenting the database.

Any help is appreciated.

Running Audirvana 3.5.17 on a 2012 quad core Mac Mini (Mojave 10.14.5).



Where are you audio files located?
On local drive? On a NAS? IF on a NAS, has the shared folder name, or the NAS name changed recently?

Files are on a local hard drive. Name has not been changed.

Ok, can you send me your library database file (the AudirvanaPlusDatabaseV2.sqlite) so I can inspect it.
It is located in ~/Library/Application Support/Audirvana
To access ~/Library with the Finder, you can use its Go menu while pressing the option (or alt) key. This reveals the Library command in this Go menu.

You may have to use a file transfer service as this can be a large file, and then send me the download link by PM or email.

I just came here to report the same issue. Duplicates can be some tracks from an album, or all tracks. I’ve confirmed that these aren’t duplicate files (and Audirvana reports the paths as being identical – per the screenshots attached). I’m on a 2012 Mac mini running 10.14.6 and the latest full release of Audirvana.

My library is stored on a Synology NAS, but nothing there has been altered recently. My workaround has been to delete and rebuild my database file periodically, a couple of times a month or so, but obviously that’s not really sustainable.



I am experiencing the same issue. The only workaround I have found is to delete the tracks to the recycle bin and then restore them. Once they are restored, only one entry for each file exists. Unfortunately, you lose play counts for the tracks by doing this.

1 Like

Damien, if you still need a database file, I can send you a link to download mine.

Same thing here, observed randomly on some albums but not others. all files are on a SYnology NAS, and nothing has changed recently in the folders naming …

This is coupled with another but similar problem: when i move an album folder from one location to another location (my way of pre assessing music, before it moves in my permanent/official library), the “old” one remains visible in A+, and A+ says the file cannot be located … Despite numerous resync, reindexing, defrag etc … nothing works! Those ghost albums remain but cannot be played…
Let me know how i can help

I’m having a similar duplicates issue - mainly duplicate tracks within an album (previously had separate duplicated albums (ie. two album covers with same tracks next to one another).

Music is all on a (Synology) NAS - with about six separate watched folders. No change of name.

I tried defragmentation first. Then I moved them to a different folder, then to unwatched folder… then deleting the relevant root folder from watched list … and back again.

Some duplicated albums Were in same watched folder.

All failed to fix the issue.

Starting a new library from scratch seems to work. But very tedious with almost 70 playlists in multiple folders.

Any other suggestions before I do that? I

same as you. I know recreating playlists is a pain when you have many.
i have kept and renamed (old) my current library and relaunched Audirvana. It has recreated a library file, i hope from scratch. i have re added my 2 watched folders last night. I need to check tonight if the recreation is successful. I think it will, because i already did it last month and it worked, but this does not mean the problem will go away permanently …
Apparently, from what i read in this forum, this is a widespread issue since version 3.5.xx … and it looks like it’s more frequent with NAS remote storage …
Some people have dared edit the SQLite file and removed some reference to watched folders, and that fixed it, but i am not that savvy and expect a permanent fix. Else i’ll go back to iTunes integrated mode. Even though i love the dark mode, i am not completly comfortable navigating in the new interface for some reasons … eg: identifying your non-tagged files is cumbersome. tagging all files in an album sometimes fails mid way, which results in some tracks getting lost in the mass …
I am frustrated :wink:

Well, I seem to have a workaround that’s working for now. I noticed that the duplicates always appear after I’ve added music to the Synology, so I’ve made a point of always quitting Audirvana before any music is moved into my watched folders. I have Audirvana set to do a scan on launch, so it picks them up only when I relaunch it. So far that seems to be working.


In other words never touch files and filders while a+ is opened, especially when remotely stored
I suspect ti me out issues in the NAS connexion but this is surprising on a wired LAN

1 Like

Yep, just so. Making sure any changes I make are done behind Audirvana’s back has been working for me so far.

1 Like

Thanks for the tip Mr_Phillip - makes perfect sense!
I meant to add that in my earlier post - noticing the correlation before… but not knowing how I could get around that.

I will try that for sure with the new library I’ve just created.
You’ve given me confidence to go through the chore of loading and organising all my playlists … with the hope I won’t have to do that again any time soon.

Perhaps Damien’s team can work on a fix for future releases.

Kudos :tophat:
Luke :seedling:

I have all of my files on an external USB hard drive. I don’t have a NAS, and I still have this ever worsening issue. I’ve even gone as far as manually deleting every duplicate I have (around 600). The duplicates return, but they’re not the same ones as before. More and more duplicates show up as time goes by.

Really hoping for a fix soon. I now avoid listening to albums in their entirety because more often than not I have to manually prune the duplicates out of the play queue.

Praying for a fix at this point.

Re: seeleemusic - did you try mr_phillip’s workaround?

I have just created a new library and will try quitting Audirvana whenever adding files.

Does anyone know if changing metadata through another app whilst Audirvana is open causes duplicates?

Or is just adding new files that messes with the library file?

Good to rule out NAS storage as the culprit (I use a Synology DS2016SE).

Dear all,

Regarding the duplicate tracks issue, I noticed on one case that such things may happen when you have on one side a list of separated tracks as individual files, and a cue file that points to those different audio files.
I do not want here to make such explanation as the unique and definitive one but I think this may explain some cases. When it happens, there is a clear identification in the tag that one source is the audio file, the second one being the cue file that points to the same audio file.

Since takin mr_phillip’s advice, my new library has held up well having introduced a number of new albums on multiple occasions.

So moving new albums into one of my watched folders only when Audirvana is shut down seems to have worked for me (so far… touch wood).

Would be great if Audirvana could fix this little bug in future releases so we don’t have to shut it down to update our library. That would be just dandy :slightly_smiling_face::pray:

(Cue files have not been the issue in my case - but were when doing file conversions in batches with XLD… but fixed that now. Obviously, that had nothing to do with Audirvana.)

1 Like

SAme here! thanks Mr Phillip!
Agree that would be best fixed in the software itself, vs with this workaround.
CUE sheets do create problems too, and i tend to delete them immediately, to avoid confusing Audirvana, who won’t know where to take metadata from … one source of truth !!! Unless the cue sheet helps to index a single file album, of course.

Going to make a new library. How do I go about doing this?

Also, will I lose my album sorting, or is that written to the files themselves?