SysOptimizer error Studio

Good morning all,

Since switching to Studio, i have an error 4 on sysoptimizer is this normal? can we correct this?

Same issue, same error, for me under macOS, Big Sur 11.3.1.

Yes, under macOS Big Sur

Logically, until this issue is not solved, we are unable to have an educated judgement on sound quality of the app, because SysOptimizer is supposed to improve it.

Exactly, It maybe an audirvana or software error on mac

Hello @Joffrey and @Doudou,

When you first started a track in Audirvana studio with Sysopt, did you get a window from MacOS?

If I stop the playback and launch a new track, I get immediately the window “Installation nécessaire” of SysOp. I allow the app to install SysOp and provide my password. But right after that I get an error 4 message, telling me SysOp could not fully install.
It happens each time I try to play a track after the playback was stopped.

I get the same as Doudou

Enable sysop and click restart all services I get this error

and then after choosing to install and entering my password I get this error

Exactly the same indeed, but in French. After that, the track plays but without SysOp optimization.

and also…

Apple hide the Home Folder in User Library at some time depending on OS System…
When you have clicked your Home Folder, and cannot see the Library Folder in there,
just do a ‘‘cmd J’’ to show the folder settings preferences and see at the bottom…
click Show Library Folder and then you’ll have access to the rest forever.

Close Audirvana.

Go to the Main Library Folder… PrivilegedHelperTools folder…

Trash All the files in that folder from Audirvana (that folder install SysOptimizer)

Go to the Main Library Folder… LaunchDaemons Folder…

Trash All the files in that folder from Audirvana (SystemOptimizer and prefs files)

Restart Mac and Audirvana and see if it installs now.

I don’t have either of those sub folders in my Mac Library folder.

me too…:unamused: I don’t have this folders.

Damien told in another thread to do those 3 commands in terminal…

sudo launchctl load -w /Library/LaunchDaemons/com.audirvana.SysOptimizerTool.plist

sudo rm /Library/PrivilegedHelperTools/com.audirvana.SysOptimizerTool

sudo rm /Library/LaunchDaemons/com.audirvana.SysOptimizerTool.plist

No such file or directory :pensive:

Same here Damien on 2 different configurations: Mac-mini / High Sierra, and PowerBook Pro / Big Sur. I have checked the directories, the files are not in .

I just checked my A+ 3.5 on an other Mac-mini, the files are in the right directories. That means that for some reason Studio cannot install these files

can you try to copy them to the same place on the mac sysopt not install

I don’t have any “PrivilegedHelperTools” folder in my library.
I have Audirvana folder inside “Application Support” folder, but there’s no “PrivilegedHelperTools” there.

So what should I do?

Yes I can do that. Just need to change “Audirvana-Plus”, by “Audirvana”. Let you know after dinner :wink: