UI Issues with Qobuz

I also get the same bad behavior with the artist navigation with my local library.

Here’s something else - my local artists that don’t show a link to their biography doesn’t have the problem. I suspect it may have something to do with so many sections in the Artist view ie: Top Tracks, Local Albums, Albums from Qobuz, Playlists with the Artist, and Album Artist Appears on, from Qobuz.

Those sections are not present if there is no Artist Bio.

No Artist Bio info, only one section showing the local album with no “See All” and no back button problems

Artist With Bio info - multiple sections with the “See All” and with the noted navigation errors.

If you go in the Streaming section in Audirvāna Studio settings, Do you have the option to get the editorial information from Qobuz?

Hello @zacster,

Can you send some screenshot of your issue?

There is an “Editorial Infos by Qobuz” slider but it can not be turned off, it is permanently On. Sliders on other Preference screens work, but this one does not.

Can you disconnect and reconnect your Qobuz account and check if you still get the same issue on Eric Clapton’s page?

Disconnected - the screens and back button function correctly
Reconnect - the problem returns

(many more screenshots of this persistent problem Problems with Artist view screen navigation)

Here are a few that I just created:

First is sys optimizer error. I stopped getting this but it started again.

This one shows the category I opened but nothing shows except the back button. Also, the currently playing bar is below my application icons bar and inaccessible. This is consistently a problem.

Here’s another. This time I’m in full screen and the top of the page is cut off and there are no scroll bars.

There is another problem I sometimes get that I can’t replicate at the moment. It usually happens if I’ve been in a session for a while where it will show the text for the icons but the icons themselves are shrunk to be invisible. I’ll send it if I ever see it again. Here’s my machine specs.

For SysOpt, you can try deleting your prefs of it:

Apple hide the Home Folder in User Library at some time depending on OS System…
When you have clicked your Home Folder, and cannot see the Library Folder in there,
just do a ‘‘cmd J’’ to show the folder settings preferences and see at the bottom…
click Show Library Folder and then you’ll have access to the rest forever.

Close Audirvana.

Go to the Main Library Folder… PrivilegedHelperTools folder…
Trash All the files in that folder from A+ (that folder install SysOptimizer).

Go to the Main Library Folder… LaunchDaemons Folder…
Trash All the files in that folder from A+ (SystemOptimizer and prefs files).

Restart MAC. Restart Audirvana, Try a song, it will ask to reinstall SysOpt and see if it works now.

For your playing bar not seen, you know you can see and hide the dock… that way, you gain an inch more of your screen always, you just have to put the mouse down the screen to make the dock coming…

I’ll give the sys optimizer a try. But yes, I know I can hide the icons but it won’t solve the problem as the play bar is below the screen cutoff. Look at my screen shot, the album icon is only half on the screen and it doesn’t scroll. I’m willing to bet that removing the icons will only make it worse as whatever the bug is it will think it has more room to display and place the play bar even lower! The top of the dock is supposed to define the usable screen area. For example, I can’t expand my Firefox window below the top.

In the meantime though, the music keeps playing and sounds great. It is just the UI that’s a problem.

If you click option key with the green button it doesn’t adjust perfectly ?

You mean the full screen button? I do and it will display properly that one time but it reverts back at some point.

This is the other thing it does. It shrunk all the icons to a point! It will go back and forth that way until I select something else.

1 Like

When it is perfect, move the right bottom corner of studio inside your screen to make the overall window smaller, then close Audirvana. Restart Mac, open audirvana, still small? Hold option key than green button and see

Does cmd + or - makes the cover grow or shrink back?

I don’t use Qobuz…

With the screen working correctly AV will not size below the dock as I just tried it. It is only on painting that is does that. A good point though that I never tried using it with less than maximized sized screen, as opposed to full screen. I wonder if it will still expand below the screen window size. I’ll have to try later.

Hello @zacster, can you please update to Big Sur? I can’t replicate your issues on my version of Audirvāna Studio on my Mac with Big Sur 11.6.4.

I’ll give it a try.

I upgraded to Monterey because Big Sur is no longer an option, but I still have the same issue.

“Press awards” shows as being open but no albums are shown, and it goes beyond the bottom of the screen.

I’ve pasted the debug info below but that seems to be more about the actual streaming. If there is something else I can provide let me know.

Audirvana Studio 1.11.0 (11100)

macOS 12.2.1 with 8GB physical RAM

Connected account of : Zachary Fisher


Polarity Inversion:
	Globally: OFF
	Per track: ON
Effects plugins NOT ACTIVE

r8brain not in use
r8brain filter parameters
Bandwidth = 99.5%
Stop band attenuation 218dB
Phase linear

Max allowed volume: 100
Replay Gain: None
SW volume control: OFF

Sync list: 0 folders
iTunes/Music library synchronization: not synchronized
Library database path: /Users/zacharyfisher/Library/Application Support/Audirvana/AudirvanaDatabase.sqlite

Remote Control server:
Listening on on port 49419

Qobuz: Connected as Qobuz Studio

=================== AUDIO DEVICE ========================

CoreAudio audio path, buffer I/O frame size: 512

Max. memory for audio buffers: 5120MB
Exclusive access: Enabled
Integer mode: Enabled

Preferred device:
Model UID:Volumio Volumio4

Active Sample Rate: 44.1kHz
Hog Mode is off

Bridge settings:
Sample rate limitation: none
Sample rate switching latency: none
Limit bitdepth to 24bit: OFF
Mute during sample rate change: OFF

Selected device:
Local audio device
ID 0x31 Built-in Output
Manufacturer: Apple Inc.
Model Name: Apple Inc. Built-in Output
Model UID: AppleHDA:51
UID: AppleHDAEngineOutput:1F,3,0,1,1:0

3 available sample rates up to 96000Hz
Audio buffer frame size : 14 to 4096 frames
Current I/O buffer frame size : 512
Volume Control
Physical: No
Virtual: Yes
MQA capability
Auto-detect MQA devices: Yes
Not a MQA device, user set to not MQA
DSD capability: Unhandled
Device audio channels
Preferred stereo channels L:1 R:2
Channel bitmap: Ox3, layout:
Channel 0 mapped to 0
Channel 1 mapped to 1

Audio channels in use
Number of channels: 2
Use as stereo device only: No
Simple stereo device: Yes

1 output streams:
Number of active channels: 2, in 1 stream(s)
Channel #0 :Stream 0 channel 0
Channel #1 :Stream 0 channel 1

Stream ID 0x32 2 channels starting at 1
3 virtual formats:
2 ch Mixable linear PCM Interleaved 32 little endian Signed Float 96kHz
2 ch Mixable linear PCM Interleaved 32 little endian Signed Float 48kHz
2 ch Mixable linear PCM Interleaved 32 little endian Signed Float 44.1kHz

3 physical formats
2 ch Mixable linear PCM Interleaved 24 little endian Signed Integer aligned low in 32bit 96kHz
2 ch Mixable linear PCM Interleaved 24 little endian Signed Integer aligned low in 32bit 48kHz
2 ch Mixable linear PCM Interleaved 24 little endian Signed Integer aligned low in 32bit 44.1kHz

Local devices found : 1
Device #0: ID 0x31 Built-in Output Manufacturer: Apple Inc. Model UID: AppleHDA:51 UID: AppleHDAEngineOutput:1F,3,0,1,1:0 Model Name: Apple Inc. Built-in Output

UPnP devices found : 3
Device #0: ID 0x0 Volumio kitchen UID: uuid:d88503d7-7853-5813-dc14-b827ebe5a427 Location:
Device #1: ID 0x0 Firestick UID: uuid:2b4bb7f8-c572-4ca2-b602-d60d9c68a2e0 Location:
Device #2: ID 0x0 Volumio boss UID: uuid:bad9105f-4ae7-6225-b302-b827ebb2e322 Location:

I’m seriously at a loss for words. The app doesn’t go behind the Dock here and Press Awards shows up with albums. It’s the same for both my M1 MacBook Pro and my 2017 MacBook Air. Both are running macOS 12.2.1 Monterey.

Does this only happen with AS or do other apps also drop behind the Dock?